Skip to main content


Funkwhale 1.0 is out 🎉

As usual, the full changelog is available at https://docs.funkwhale.audio/changelog.html#id1,. New features include:

- A brand new search page
- It's now possible to launch a scan from the UI
- Themes and language are now persisted accross sessions
- A new plugin system, with a scrobbler plugin that works with Last.fm and MusicBrainz

We're thankful to the contributors to this release, as well as all our supporters, backers and members of the community who have been with us for five years!

We wish you a happy upgrade!

5 people reshared this

Hi Funkwhale - I've tried to use the open.audio instance a few times, but never been able to upload anything.

This version now says I have no space left and need to "contact the moderators" when I try but doesn't actually suggest any way to do that. The add content page says I should have 3GB.

The links in the "Getting help" section all seem to be for developers, not end-users.

Am I missing something? Is my account broken?
what is your username on open.audio and what do you plan to upload?
it's "mike" same as here.

I hadn't really thought much about use, I figured on chucking a couple of my old band's tracks on to see how it behaved. Kind of interested to see if it's viable for podcast publishing, can it generate a valid feed for those?
I've gave you some upload storage, you should be able to publish your tracks now :)

And yes, we publish a valid podcast RSS feed that is compatible with other appllications
Thanks, I'll take a look.

Did I do something weird when I signed up? I've been logging in every now and then for about a year thinking there was just some kind of bug stopping it from working, but since you put a 1.0 on it, I figured there might be a problem with just my account.
you did nothing wrong, we closed registrations a while ago, and only granted upload storage to new accounts :)
Congrats for this major milestone @agate! and all the contributors of course @GinnyMcQueen
Congratulations with major release :)

Maybe it is just me but I noticed that with the new version search now shows results from private libraries on the server. I am not sure if it is a bug or intended behavior so I opened support thread. It can be a potential liability for someone.

Or was it like this before? Can someone who haven't updated yet check if this happens on older version?
it was like this before, right now this is the expected behaviour :)
Thanks for explanation. I hope it will become unexpected behavior someday :)

Private libraries should stay private in my opinion.
Thanks and congrats! Is there a list where one can view which instances has upgraded to 1.0?
you can find the list of pods and their version at https://network.funkwhale.audio/dashboards/ :)
:blobheart:
Thanks for a great piece of software! Liberta Audio now runs Funkwhale 1.0, keep up the veeeeery good work! Cheers

Funkwhale reshared this.

will there be an announcement on twitter as well so I can share it on @FediSupport?
Thank you, we forgot to make the Twitter announcement, it's been corrected :3

https://twitter.com/funkwhaleaudio/status/1306509949204410368